From: Ron Jeffries Date: 2002-01-15T23:33:05+09:00 Subject: Re: Small Methods - a ramble On Tue, 15 Jan 2002 13:12:02 GMT, Chris "boris" Ross wrote: >My teacher at school alway wittered on about meaningful identifiers (this was >in pascal) and so I then made a point to make each variable name 256 >characters. He was less than pleased - but it was readable >BecauseWeHadToWriteThemLikeThis :) But even to this day I still stick to >hacking out a method using bad identifiers and then go back and give them the >correct names (once I actually know what they are for) - most people seem to >forget the second step =P Maybe sometimes even /you/ forget the next step: I know I do. So as I program, I think about what I'm intending to do. If I'm intending to create a variable that contains all interesting file names, I call it something like interestingFileNames or interestingNames or at least fileNames. I find that focusing on my intention makes my code better, and writing down my intention makes it less necessary to clean up after. Regards, Ronald E Jeffries http://www.XProgramming.com http://www.objectmentor.com I'm giving the best advice I have. You get to decide whether it's true for you.