From: Tommy Morgan Date: 2008-08-14T06:03:55+09:00 Subject: Re: Redefine "method" method ------=_Part_43386_12309649.1218661594499 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: quoted-printable Content-Disposition: inline Well, for what it's wirth: I think request.sip_method is actually better. While it's important to try and go for naming conventions in your code that are succinct, you also want to avoid ambiguity. If someone else is looking at your code and they see 'request.method', it isn't obvious that you are referring to something aside from what is built into ruby. sip_method helps to avoid that ambiguity, and it also allows you to go back and utilize the built-in method if you need to at some point in the future. Hope that helps. --Tommy M. On Wed, Aug 13, 2008 at 4:46 PM, I=F1aki Baz Castillo wrote= : > El Mi=E9rcoles, 13 de Agosto de 2008, Tommy Morgan escribi=F3: > > Any chance you could just use a different name for your method? > > Of course, but I'm doing a SIP protocol application, in which a core > concept > is the *method* (INVITE, ACK, BYE...), so it would be really nice to use: > > request.method > > instead of: > > request.sip_method <--- This is what I use for now. > > Thanks. > > -- > I=F1aki Baz Castillo > > ------=_Part_43386_12309649.1218661594499--