From: Saku Ytti Date: 2008-04-12T05:07:17+09:00 Subject: Re: delete_if, select and (lack of) delete_if!, self.POLS == false On (2008-04-12 04:54 +0900), David A. Black wrote: > There's no general principle at stake; I'm just saying that if you > want a method that behaves like select but performs an in-place > reject, it's better to invent a name than override Enumerable#reject!. I see what you mean, and I fully agree that changing existing methods would cause lot of inconvenience. Kinda just wish this functionality would be built-in (for performnce reasons), and select!, reject!, delete_if! might be feasible candidates from different points of view, if there wasn't history as a burden. Anyhow than you for your insight. -- ++ytti