From: Eric Hodel Date: 2008-03-30T11:08:51+09:00 Subject: Re: Unit test filename convention On Mar 29, 2008, at 16:19 PM, Manlio Malaidini wrote: > All, > > I'm just starting with Netbeans 6.1 after having used Eclipse RDT > for a > while. I was used to keep unit tests within the same file (delimited > by > if $0 == __FILE__), but now I guess there's a shift towards separate > files. > > Which is the current trend in the community for what is related to > unit > tests filename? I've never bought into the TC_* style, it's ugly and > fairly disruptive. What about yada_test.rb for class Yada defined in > yada.rb? lib/yada.rb # class/module Yada test/test_yada.rb # class TestYada < Test::Unit::TestCase (Which works out-of-the-box with autotest, but since you're using Eclipse, you probably don't care.)