From: "mcf1986@..." Date: 2008-03-20T22:19:59+09:00 Subject: Re: ruby-net-ldap On Feb 24, 1:56 am, imdwalrus wrote: > I'm running ruby 1.8.6 on Windows.  I've installed the ruby-net-ldap > 0.0.4 gem.  When I require 'net/ldap' I get nothing.  All calls to > ruby-net-ldap methods fail.  I've used this gem successfully in > another project and I > just can't figure out what I'm doing wrong now. > > I ran the following tests in the project where it's failing: > > C:> gem list > .. > ruby-net-ldap (0.0.4) > .. > > C:> path > ..;c:/RoR/Ruby/bin;...     > > irb>$:.each {|dir| puts dir } > .. > c:/RoR/Ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/bin > c:/RoR/Ruby/lib/ruby/gems/1.8/gems/ruby-net-ldap-0.0.4/bin > c:/RoR/Ruby/lib/ruby/gems/1.8/gems/ruby-net-ldap-0.0.4/lib > .. > > irb> require "net/ldap" > [  ] > > So the gem is there, the directory is in the load path, but the > require statement isn't finding it.  I confirmed that c:/RoR/Ruby/lib/ > ruby/gems/1.8/gems/ruby-net-ldap-0.0.4/lib/net/ldap.rb exists.  The > only differences I can see between the instance that works and this > one is that the former uses ruby 1.8.5 and Rails 1.2 and the latter > uses ruby 1.8.6 and Rails 2.0.2.  I've also tried this under Parallels > on my Macbook using Ruby 1.8.6 and Rails 2.0.2 and it fails there > too. > > I don't know what else to check.  Can someone enlighten me, please? > > -- Mike I have the same problem from upgrading Ruby 1.8.6, I can't see why this is broken. Going to implement OpenID in the mean time. Did you manage to fix this issue? Matt