From: Ron Jeffries Date: 2001-12-23T12:37:02+09:00 Subject: [ruby-talk:29343] Re: a better way? Thanks all ... so far I like the two lines best. The version with the and is good too but I don't like the way the "and" reads, since it really means "and only if the cache has a hit" or something. Thanks again! Ronald E Jeffries http://www.XProgramming.com http://www.objectmentor.com