From: "t3ch.dude" Date: 2008-02-29T03:24:55+09:00 Subject: Re: Named sprintf parameters On Feb 28, 11:57 am, Trans wrote: > I have a question and perhaps a bit of challenge for those with mad > parse skills: Has anyone ever considered named parameters for sprintf/ > printf? It would be quite useful (to me at least) to be able to do: > >   "I am %(name)s." % { :name => "Tom" ] > > Has anyone worked on something like this before? Is there anything > equivalent in the Perl world or other language? I realize we can use > numerals to identify the substitutions, but I feel the labels are much > more readable. Moreover, ultimately it would be interesting to see: > >   "I am %(name)s." % binding > > Making use of the binding's local_variables. > > The challenge, of course, is to override printf/sprintf to do this > (the binding part gets you extra ruby points ;-)  Even more > challenging, augment the C code to handle it and submit it as a patch. > > T. That exact feature exists in that form in Python today... http://docs.python.org/lib/typesseq-strings.html -T3ch Dude