From: Gary Wright Date: 2008-02-16T07:42:22+09:00 Subject: Re: Proper way to RDoc markup? not quite On Feb 15, 2008, at 5:28 PM, Jeremy McAnally wrote: > I guess...? You just need to pay attention to what you're doing. :P > I personally think this is more readable than inlining: > > # This does something fun > attr_reader :fun > > # This does something writable > attr_accessor :read_write > > # This does something AWESOME > attr_accessor :forty_two Yuck, that is 8 lines vs. 3 (below). I always found it strange that RDOC didn't parse comments to the right of an accessor declaration yet that is exactly how attributes are documented in the HTML pages generated by RDOC. attr_reader :fun # This does something fun attr_accessor :read_write # This does something writable attr_accessor :forty_two # This does something AWESOME Gary Wright