From: Mitch Mitch Date: 2008-02-12T14:05:43+09:00 Subject: Re: DRb rescue: Shouldn't this be changed? > however more googling indicates that your problem, and the use of > RangeError does seem to be correct. I now think I get why you were > doing: > > rescue > delete_observer(i) > end > > in there. That seems as reasonable patch as any to me to accomplish > what you're trying to do. Thanks for the additional information. I just want to make sure that I was clear. The code: begin ... rescue delete_observer(i) end is not my patch, but the code in the current release of DRb (drb/observer.rb). The patch I added in my code is: begin ... rescue RangeError delete_observer(i) end -- Posted via http://www.ruby-forum.com/.