From: Luis Lavena Date: 2007-12-21T03:25:00+09:00 Subject: Re: gem_server On 19 dic, 08:11, Oliver Robinson wrote: > Have just installed a clean ruby 1.8.5 on windows and ran: > > gem update --system > > the rdoc server fails to load the index page with an internal server > error: uninitialized constant Gem::DocManager. > > Any ideas? > > Full stack trace: > > C:\programfiles>gem_server All the gem_server, gemlock, gemwhich and other gem* batch files have been "deprecated" in favor of gem : so gem_server became gem server the problem is that gem update --system isn't doing the same job that setup.rb is doing: replacing older batch stubs with "stubs" that indicate deprecation. HTH, Luis