From: Brian Adkins Date: 2007-12-12T23:25:03+09:00 Subject: Re: opposite .nil? On Dec 11, 7:02 pm, Ken Bloom wrote: > Here's a more readable construct: Hmm... maybe 'readable' is in the eye of the beholder ;) > def should_this_be_done? > am_I_sure? and my_object and not my_object.var.nil? > end Folks should be aware of the difference in precedence. In particular, && has a higher precedence than =, but 'and' has a lower precedence than =. > You're not forced to program Ruby like it's C. Agreed > > --Ken