From: Andrew Stone Date: 2007-12-12T05:03:53+09:00 Subject: Re: opposite .nil? ------=_Part_31259_27276253.1197403434830 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Content-Disposition: inline > 1) No such opposite-of-nil? method exists. If you want it, add it. > Thanks for actually answering my question. Much appreciated. 2) In the particular example above (which I realize is just an > example) you could write that as: > > def should_this_by_done? > am_I_sure? unless !my_object || my_object.var.nil? > end > > But, of course, that just moves the negation. > > Sure, I was just looking for a more readable construct. Thanks again for your reply. -- Andrew Stone ------=_Part_31259_27276253.1197403434830--