From: Robert Klemme Date: 2007-11-22T00:30:30+09:00 Subject: Re: porting java methods to ruby 2007/11/21, Jari Williamsson : > Robert Klemme wrote: > > > Actually, we can make this even *more* rubyish: > > > > def get_text_characters holder_for_start_and_length > > end > > Is it actually more rubyish to omit the parenthesis? I often find it > much harder to read, specially in e-mails with a variable-spaced font. I left that to optimize for someone else. ;-) Seriously: most of the time I use brackets in method definitions - not necessary usages. Kind regards robert -- use.inject do |as, often| as.you_can - without end