From: "ara.t.howard" Date: 2007-11-07T02:03:24+09:00 Subject: Re: named parameters idiom On Nov 6, 2007, at 4:46 AM, Fernando Cacciola wrote: > > It worries me that while it adds clarity at the point of call, it > takes it away at the function defintion point, so I haven't dare to > use it yet. def another_idiom options = { :can => 'be enumerated here for clarity', :if => 'you want the signature to be more declarative' } end cheers. a @ http://codeforpeople.com/ -- we can deny everything, except that we have the possibility of being better. simply reflect on that. h.h. the 14th dalai lama