From: Peter Szinek Date: 2007-11-06T20:32:38+09:00 Subject: Re: Passing all parameters to a method with a unique variable Mario Ruiz wrote: > Thanks for your comments. > This is only an example the real name of my global variable is: > $txLoginData That's only a bit better :-). The Ruby convention would be to call it tx_login_data in this case. However, this is really up to you as far as you are consistent in naming your variables (or you'd like to merge your code later with somebody using different naming conventions, e.g. Ruby's). What's worse is the usage of global variables which is not recommended. I am not sure what are you working on though - maybe you are porting something over from a different language which is full of global variables, and you are not going to use this code too much in the future. However, if that's not the case, and mainly if you are writing the code from scratch, factoring out the global variables would be a good idea in 99.9% of the cases... 2c, Peter ___ http://www.rubyrailways.com http://scrubyt.org