From: nobrow Date: 2007-10-13T19:10:02+09:00 Subject: Ruby + Apache, scripts not being interpreted I am trying to get Ruby running on Apache. I may or may not have a problem. What do you think? I have a test site called ruby-test set up with a vhost. When I go to rails-test/ I see the "Welcome Aboard" page. But when I click the "About your application's environment" link the script doesnt get interpreted ... I just see it as text. I havent gone any further than this, as I have been trying to get that script to run. rails-test/public/.htaccess looks like: AddHandler fcgid-script .fcgi Options +FollowSymLinks +ExecCGI RewriteEngine On RewriteRule ^$ index.html [QSA] RewriteRule ^([^.]+)$ $1.html [QSA] RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ dispatch.fcgi [QSA,L] ErrorDocument 500 "

Application error

Rails application failed to start properly" The vhost .conf for the site looks like: DocumentRoot "/var/www/webroot/rails-test/public" ServerName rails-test Options ExecCGI FollowSymLinks AllowOverride all Order allow,deny Allow from all Is the problem that the .rb file that the link points to is in a directory that doesnt have +ExecCGI set? What must I do to fix this? Am quite stuck. I guess one solution is to get mod_ruby working right? But I cant figure out how to check if it is working already, or find a set of instructions how to install it. Help greatly appreciated, thanks.