From: Chris Lowis Date: 2007-08-16T02:04:37+09:00 Subject: Re: 24 seconds for FASTCGI process to startup??? Is this nor > Any ideas on whether this approach would assist in keeping more than 1 > fastcgi? I note that there are 2-3 processes fastcgi ruby processes > that > Dreamhost seems to kickoff when I hit the website (I'm not sure where > this > number is specified). I'm not sure where I got this tip from, but try adding this to your crontab : 10 1 * * * ps aux|grep username|grep dispatch|awk '{print $2}'|xargs kill -9 (replace username with your dreamhost username). It periodically kills dispatch processes, which are then recreated by the app. It seems to keep the number of dispatch processes for my app to around 3. Without it, I found a lot of stale processes were created. If I recall, this can be caused by errors in your app (check production.log), so perhaps I don't need this anymore. But it doesn't seem to hurt! Hope this helps, Chris -- Posted via http://www.ruby-forum.com/.