From: Curt Sampson Date: 2007-08-10T13:28:57+09:00 Subject: Changing Test::Unit::Assertion messages In many of my tests, I do something along the lines of assert_match(/foobar/, content) When the assertion fails, it prints out something resembling the inspect of the content. In some cases, it's much more readable to print something different. How do I do that for this one case, but leave the default behaviour for other cases in the program. I thought it would be as simple as overriding the inspect method on content, but that doesn't do the trick. I've been through the internals of Test::Unit::Assertion, and it seems to frustrate this effort. cjs -- Curt Sampson +81 90 7737 2974 http://www.starling-software.com The power of accurate observation is commonly called cynicism by those who have not got it. --George Bernard Shaw