From: Trans Date: 2007-08-03T10:31:17+09:00 Subject: Re: #send in 1.9 On Aug 2, 9:05 pm, Daniel DeLorme wrote: > > This topic again? I've lost count of how many threads I've read about > the naming of send/funcall. Has anyone kept a full list of the numerous > suggestions? I can remember: > > (public-only) > send > __send > __send__ > object_send > > (all) > funcall > send! > __send! > instance_send Not quite. This time I'm asking that we do the opposite. Pick a new name for "public send" and leave the old one alone. (Of course, possibly someone else suggested it before, but I don't recall). T.