From: Andrea Maschio Date: 2007-08-02T04:27:43+09:00 Subject: Re: Dynamic method call ------=_Part_20785_24876215.1185996466704 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Content-Disposition: inline the problem is that method_name is a static call, i need to make it dynamic and choosed by the user/programmer, so at least he should type eval("method_name(arg1,arg2)") if condition but my aim was just to encapsulate this in a more comprehensible grammar like if_it_happens_that(is_true, "do_something(arg1,arg2)") in another language that english it sound more different using english word "like if, then, end, do" i know it could sound weird, but this was my need, and i solved it with eval (of course the internal logic is far more complex) 2007/8/1, Gregory Brown : > > On 8/1/07, Andrea Maschio wrote: > > Thank you very much guys, it worked. I was doing this for the purpose of > > create a scripting language in my lang for testers to easy developing of > use > > case testing with watir. > > For english people is probably easier to read > > you really think that's easier to read than: > > method_name(2,3) if condition > > ??? > > -- Andrea Maschio http://www.superandrew.it A clever person solves a problem. A wise person avoids it. Einstein ------=_Part_20785_24876215.1185996466704--