From: Jano Svitok Date: 2007-07-12T23:54:27+09:00 Subject: Re: Win32-service: error 5: access denied On 7/11/07, Michael Dichtl wrote: > hello altogether! > > I have written an win32 service like explained in O'Reilys "Ruby > Cookbook" on page 750. > > when i try to start the service is get the following error: > Zugriff verweigert (Win32::ServiceError) > or when i try to start the service manually: > Fehler 5: Zugriff verweigert > (in english: error 5: access denied) > > does anyone know how to fix this? What system do you have? XP/W2k/vista? Is the service already registered? (Can you see it in services?) Can you start it with net start ? Are you admin? Uberadmin in vista? Can you start/stop other services? Could you post the code you are trying to start? Could you post the actual command (what did you do when you tried to start the service)? What do you do in your service? You cannot use stdin, stdout, stderr; You don't see mapped/subst-ed disks, You might not have rights to some files - you are most probably running under SYSTEM user. (Now I see this looks like a confession recipe ;-) J.