From: Robert Dober Date: 2007-07-11T23:54:16+09:00 Subject: Re: Yield should be renamed call_block On 7/11/07, Phrogz wrote: > > This native-English speaker concurs: "accept" is not at all a good > method name for a block/proc to say "please run yourself". Better I > think is (as I already posted) "run". :) It's both short and > representative. I support my supporters ;) #run is great ( I can live with #call though, notwithstanding your correct reasoning against it ) Robert -- I always knew that one day Smalltalk would replace Java. I just didn't know it would be called Ruby -- Kent Beck