From: Chris Carter Date: 2007-07-11T23:41:40+09:00 Subject: Re: Yield should be renamed call_block On 7/11/07, John Joyce wrote: > > On Jul 11, 2007, at 8:50 AM, Phrogz wrote: > > > On Jul 11, 2:37 am, "Robert Dober" wrote: > >> On 7/11/07, dbl...@wobblini.net wrote: > >>> On Wed, 11 Jul 2007, Chad Perrin wrote: > >>>> Is the word "accept" being used for anything? > >>> $ ri Proc#accept > >>> Nothing known about Proc#accept > >> > >>> Doesn't look like it :-) > >> > >> Too bad because I could not accept accept ;) > >> Seriously, accept what, to be run? > >> Well if you native speakers think it is good, I will shut my mouth, > >> but it really sounds strange to me. > > > > This native-English speaker concurs: "accept" is not at all a good > > method name for a block/proc to say "please run yourself". Better I > > think is (as I already posted) "run". :) It's both short and > > representative. > > > > > Oh! I like run!! Proc#run() > What about do??? proc#do() > execute > perform > workon > attend > attendto > complete > > Why are we just throwing aside the perfectly named method #call with it's alias to #[]? The pattern of naming methods #call for action objects is getting more and more common, especially now that Rack uses it. And it really does explain what is going on. I don't think we need that many more alias' in Proc. I agree that Proc#yield is wonko, and that yield should stay in the current incarnation, but why are we all about losing Proc#call? -- Chris Carter concentrationstudios.com brynmawrcs.com