From: John Joyce Date: 2007-07-11T23:35:55+09:00 Subject: Re: Yield should be renamed call_block On Jul 11, 2007, at 8:50 AM, Phrogz wrote: > On Jul 11, 2:37 am, "Robert Dober" wrote: >> On 7/11/07, dbl...@wobblini.net wrote: >>> On Wed, 11 Jul 2007, Chad Perrin wrote: >>>> Is the word "accept" being used for anything? >>> $ ri Proc#accept >>> Nothing known about Proc#accept >> >>> Doesn't look like it :-) >> >> Too bad because I could not accept accept ;) >> Seriously, accept what, to be run? >> Well if you native speakers think it is good, I will shut my mouth, >> but it really sounds strange to me. > > This native-English speaker concurs: "accept" is not at all a good > method name for a block/proc to say "please run yourself". Better I > think is (as I already posted) "run". :) It's both short and > representative. > > Oh! I like run!! Proc#run() What about do??? proc#do() execute perform workon attend attendto complete