From: Robert Dober Date: 2007-07-11T20:18:52+09:00 Subject: Re: Yield should be renamed call_block On 7/11/07, Chad Perrin wrote: > On Wed, Jul 11, 2007 at 06:08:12PM +0900, Martin DeMello wrote: > > On 7/11/07, dblack@wobblini.net wrote: > > > > > >I suspect that if we didn't have the 'yield' keyword and the process > > >of making a transition to having it be message-style, I don't think > > >"yield" would ever show up as a suggestion for a name for this method > > >(though of course an astonishing number of terms show up in the > > >various free-for-all method-name suggestion fests :-) > > > > block.eigenyield # :) > > This may be a job for . . . > > Eigeneigen!!! Difficult to parse I know ;) Eigen* R. -- I always knew that one day Smalltalk would replace Java. I just didn't know it would be called Ruby -- Kent Beck