From: John Joyce Date: 2007-07-11T17:49:18+09:00 Subject: Re: Religion (was: god 0.1.0 released) On Jul 10, 2007, at 11:54 PM, Robert Oliver wrote: > I agree with you and wondered the reasoning for the "kill" command > myself. > > Is it just me, or as ActiveRecord's .destroy method seemed a bit > too much? > Isn't .delete enough? :) > > Robert > I think there was probably some reasoning behind it. Delete is arguably overused and people might be desensitized to it. 'destroy' really does give the sense that if you destroy it, it is not coming back! It would be interesting to hear the rationale on some naming schemes in the Rails stuff. Many if not most are sensible, but some are just bizarro sometimes or worse, incongruent. acts_as_tree should have been has_and_belongs_to_self