From: Chad Perrin Date: 2007-07-11T09:33:08+09:00 Subject: Re: Yield should be renamed call_block On Wed, Jul 11, 2007 at 09:28:14AM +0900, dblack@wobblini.net wrote: > > On Wed, 11 Jul 2007, Chad Perrin wrote: > >On Wed, Jul 11, 2007 at 07:36:34AM +0900, ara.t.howard wrote: > >> > >>i'm with matz on this one > >> > >> block.yield > >> > >>reads, to me, simple as > >> > >> 'doing my own thing...' > >> > >> block.yield 'control to you' > > > >Speaking more generally . . . > > > >The way I've always read the object.message syntax is that you're saying > >something like "Hey, Object! I want you to [yield]." Substitute the > >particular message you're sending for [yield] as necessary. > > Exactly -- blocks don't yield, so let's not ask them to :-) Is the word "accept" being used for anything? -- CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ] Isaac Asimov: "Part of the inhumanity of the computer is that, once it is completely programmed and working smoothly, it is completely honest."