From: Chad Perrin Date: 2007-07-11T09:06:31+09:00 Subject: Re: Yield should be renamed call_block On Wed, Jul 11, 2007 at 07:36:34AM +0900, ara.t.howard wrote: > > i'm with matz on this one > > block.yield > > reads, to me, simple as > > 'doing my own thing...' > > block.yield 'control to you' Speaking more generally . . . The way I've always read the object.message syntax is that you're saying something like "Hey, Object! I want you to [yield]." Substitute the particular message you're sending for [yield] as necessary. -- CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ] print substr("Just another Perl hacker", 0, -2);