From: Bharat Ruparel Date: 2007-07-10T23:52:24+09:00 Subject: Re: Yield should be renamed call_block > I've always thought of the yield mechanism as one of the most > strikingly elegant and expressive things in Ruby. (More subjective > judgment :-) I'm actually very surprised to hear that it's likely to > disappear, or change considerably. > I think that Matz is on to something again! The more I think of yeild as a method on an object, less it bothers me. I have the mental crutch of being able to alias it anytime I wish. Therefore, it does not seem like a big deal anymore whereas as a keyword it is a big deal to me. I guess the reason is that I am comfortable dealing with different method names meaning the same thing in ruby, e.g., map and collect. I prefer map to collect. I believe that as a rule, the language keywords should be as natural as possible whereas library method names can and should be customizable. Bharat -- Posted via http://www.ruby-forum.com/.