From: James Edward Gray II Date: 2007-07-10T23:28:19+09:00 Subject: Re: Beautiful Code : Pity he didn't ask here... On Jul 10, 2007, at 9:24 AM, Paul Battley wrote: > On 10/07/07, James Edward Gray II wrote: >> I've also recently adopted the trick of using _ as an unused >> parameter name. I believe it was Ara that first suggested this and I >> think it's a great idea: >> >> hash.sort_by { |key, _| � }� > > I thought it came from Haskell, where _ is a wildcard parameter: I meant that I believe it was Ara who recommended it as a good name for an unused block parameter in Ruby. James Edward Gray II