From: Robert Dober Date: 2007-07-10T21:32:43+09:00 Subject: Re: Yield should be renamed call_block On 7/10/07, dblack@wobblini.net wrote: Sorry for the second post :( > > I've always thought of the yield mechanism as one of the most > strikingly elegant and expressive things in Ruby. (More subjective > judgment :-) I'm actually very surprised to hear that it's likely to > disappear, or change considerably. I missed that point. I completely agree with you, I *need* &blk -- with or without sigil ;) -- and I need yield, absolutely !!! R.