From: Robert Dober Date: 2007-07-10T21:30:52+09:00 Subject: Re: Yield should be renamed call_block On 7/10/07, dblack@wobblini.net wrote: > Hi -- > > Interesting -- I didn't know that would happen. However, I think > James's point was about using the block in a variable in the method > (e.g., for calling another method using the same block). Am I missing something here? def x y &Proc.new end that would be the equivalent to the preferred def x &blk y &blk end Right? Robert -- I always knew that one day Smalltalk would replace Java. I just didn't know it would be called Ruby -- Kent Beck