From: Robert Dober Date: 2007-07-10T19:58:15+09:00 Subject: Re: Yield should be renamed call_block On 7/9/07, James Edward Gray II wrote: > On Jul 9, 2007, at 8:27 AM, John Joyce wrote: > > the '&' sigil is kind of scary. Reminds me of C. I'd be > > disappointed to see Ruby get more sigils. > > That's nothing new for Ruby. It works today. It's also needed. I am with you here the & makes code more readable for me. > Without it, it wouldn't be possible to save a block into a variable > for later use. That is not true though def return_given_block Proc.new end p = return_given_block { puts 42 } p.call > > James Edward Gray II > > Cheers Robert -- I always knew that one day Smalltalk would replace Java. I just didn't know it would be called Ruby -- Kent Beck