From: Bertram Scharpf Date: 2007-07-10T18:31:33+09:00 Subject: Re: Yield should be renamed call_block Hi, Am Dienstag, 10. Jul 2007, 13:28:27 +0900 schrieb Yukihiro Matsumoto: > In message "Re: Yield should be renamed call_block" > on Tue, 10 Jul 2007 09:10:07 +0900, Bertram Scharpf writes: > > |> If you check explicitly, yes. But implicit is better than explicit, > |> if you and computer feel same way. > | > |There is a implication uncertainity relation: either > |`&block' is implicit or `raise if block_given?' is. > > I meant 'raise if block_given?' being explicit Sorry. This discussion really drives me round the bend. Bertram -- Bertram Scharpf Stuttgart, Deutschland/Germany http://www.bertram-scharpf.de