From: Yukihiro Matsumoto Date: 2007-07-10T13:28:27+09:00 Subject: Re: Yield should be renamed call_block Hi, In message "Re: Yield should be renamed call_block" on Tue, 10 Jul 2007 09:10:07 +0900, Bertram Scharpf writes: |> If you check explicitly, yes. But implicit is better than explicit, |> if you and computer feel same way. | |There is a implication uncertainity relation: either |`&block' is implicit or `raise if block_given?' is. I meant 'raise if block_given?' being explicit matz.