From: Yukihiro Matsumoto Date: 2007-07-10T08:05:04+09:00 Subject: Re: Yield should be renamed call_block Hi, In message "Re: Yield should be renamed call_block" on Tue, 10 Jul 2007 06:51:03 +0900, Florian Gross writes: |Currently, it is still possible for the method to check for blocks it |doesn't want by itself, though. (raise if block_given?) If you check explicitly, yes. But implicit is better than explicit, if you and computer feel same way. matz.