From: Florian Gross Date: 2007-07-10T06:51:03+09:00 Subject: Re: Yield should be renamed call_block > Rationals are: > > * you can detect methods that don't take blocks, that > currently ignored silently. Currently, it is still possible for the method to check for blocks it doesn't want by itself, though. (raise if block_given?)