From: dblack@... Date: 2007-07-10T00:48:27+09:00 Subject: Re: Yield should be renamed call_block Hi -- On Mon, 9 Jul 2007, Simen Edvardsen wrote: > On 7/9/07, John Joyce wrote: >> the '&' sigil is kind of scary. Reminds me of C. I'd be disappointed >> to see Ruby get more sigils. >> >> >> > > What are you talking about? The &-sigil in the argument list isn't a > proposed change, it's there already, so Ruby wouldn't be getting any > more sigils. I think he's talking about the fact that this: def x yield end would no longer be possible (as I understand it). So, in practice, more Ruby code would have more & characters. David -- * Books: RAILS ROUTING (new! http://www.awprofessional.com/title/0321509242) RUBY FOR RAILS (http://www.manning.com/black) * Ruby/Rails training & consulting: Ruby Power and Light, LLC (http://www.rubypal.com)