From: Simen Edvardsen Date: 2007-07-10T00:43:50+09:00 Subject: Re: Yield should be renamed call_block On 7/9/07, Bharat Ruparel wrote: > 2. I think that moving "yeild" to a method call is a great idea. That > way it can be freely aliased as and when needed. Why are you saying > that it will be done that far out (3.0?). Are you concerned about > "breaking" existing code? Educate me. > > Thanks. > > Bharat > > -- > Posted via http://www.ruby-forum.com/. > > I think that in general, stuff that relies on implementation details such as yield (you must lookup the block in the current scope) is a language feature, and should be treated as such. The alternative would be if Ruby provided a cross-platform interface to the interpreter, but I don't see that happening anytime soon. Also, aliasing "yield" would lead to confusion. I think it's good to enforce consistency in this case. -- - Simen