From: Yukihiro Matsumoto Date: 2007-07-10T00:43:40+09:00 Subject: Re: Yield should be renamed call_block Hi, In message "Re: Yield should be renamed call_block" on Mon, 9 Jul 2007 23:59:35 +0900, Bharat Ruparel writes: |1. I have to plead ignorance. I do not know the language history very |well. What is CLU? CLU is a programming language designed in MIT back in 70s. CLU has a functionality called an iterator which fundamentally equals to a method call with a block in Ruby, except that a iterator must be called within a for statement. For more information, Google is your friend. |2. I think that moving "yeild" to a method call is a great idea. That |way it can be freely aliased as and when needed. Why are you saying |that it will be done that far out (3.0?). Are you concerned about |"breaking" existing code? Educate me. I think incompatibility can be introduced time to time in the evolution of languages. I try not to make them too often though. matz.