From: Simen Edvardsen Date: 2007-07-09T22:34:17+09:00 Subject: Re: Yield should be renamed call_block On 7/9/07, John Joyce wrote: > the '&' sigil is kind of scary. Reminds me of C. I'd be disappointed > to see Ruby get more sigils. > > > What are you talking about? The &-sigil in the argument list isn't a proposed change, it's there already, so Ruby wouldn't be getting any more sigils. As for the aliasing yield-thing, it can't be done in Ruby, because it depends on the local scope (maybe with hacks such as Binding.of_caller, I'm not sure) . You'd need to inspect the stack, which can't be done in Ruby and would rely on implementation details in C. It just isn't worth it. -- - Simen