From: Martin DeMello Date: 2007-07-09T22:08:28+09:00 Subject: Re: Yield should be renamed call_block On 7/9/07, Yukihiro Matsumoto wrote: > > def ntimes(n, &b) > n.times do > b.yield > end > end It reads wrong, now, though - the block isn't yielding, the current method is yielding *to* the block. #run might be a better method name. martin