From: Chad Perrin Date: 2007-07-09T14:39:15+09:00 Subject: Re: Yield should be renamed call_block On Mon, Jul 09, 2007 at 09:58:23AM +0900, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: Yield should be renamed call_block" > on Mon, 9 Jul 2007 09:10:23 +0900, Bharat Ruparel writes: > > |I find it fascinating and quite a bit true. However, I have to always > |mentally translate the keyword "yeild" to mean "call_block". > > The "yield" keyword is used for this purpose from the ages of > languages for example in CLU. So if you learn the history and the > culture, you will find less problem. > > I am not going to rename it. But in far future (3.0? maybe), the > keyword will be removed from the language, and you will access blocks > via block arguments of methods. That sounds pretty good -- and more consistent across the language, too. -- CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ] Isaac Asimov: "Part of the inhumanity of the computer is that, once it is completely programmed and working smoothly, it is completely honest."