From: John Joyce Date: 2007-07-09T12:43:57+09:00 Subject: Re: Yield should be renamed call_block On Jul 8, 2007, at 7:58 PM, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: Yield should be renamed call_block" > on Mon, 9 Jul 2007 09:10:23 +0900, Bharat Ruparel > writes: > > |I find it fascinating and quite a bit true. However, I have to > always > |mentally translate the keyword "yeild" to mean "call_block". > > The "yield" keyword is used for this purpose from the ages of > languages for example in CLU. So if you learn the history and the > culture, you will find less problem. > > I am not going to rename it. But in far future (3.0? maybe), the > keyword will be removed from the language, and you will access blocks > via block arguments of methods. > > matz. > to the OP, Of course with your won individual modules/libraries loaded/required, you can alias yield to be whatever isn't already taken by something else. Ideas for aliases: yield_to, call_block, step_out, segway, divert, fork, short_fork, lunch_break, junk_time, call_junk, goto ((hehehe...)) John Joyce