From: Bharat Ruparel Date: 2007-07-09T09:10:23+09:00 Subject: Yield should be renamed call_block One of the virtues of the Ruby language that is touted by just about everyone including the language designer Matz is that it is supposedly very intuitive, follows principle of least surprise, duck typing and on and on. I find it fascinating and quite a bit true. However, I have to always mentally translate the keyword "yeild" to mean "call_block". I find that it is the biggest distraction that I have when I am trying to figure out what and how a a method with a block and calling code interact. I can understand all that baggage such as "lambda" function name from Lisp and the wonderful "$" variables that came from Perl, but where did the keyword yeild come from? And why has not anyone aske Matz to consider changing it to infinitely more obvious "call_block"? It it that big a deal? In an open source language? -- Posted via http://www.ruby-forum.com/.