From: Carlos Date: 2001-11-19T19:47:51+09:00 Subject: [ruby-talk:25835] Re: Translating ruby method names - opinions wanted > fred.sort_me or fred.sortMe > fred.compact_me Mmmm... Is not 'yourself' better? I mean, you are talking to fred (sending message to object fred), and you are asking it to compact intself, not you. fred.compact_yourself == "Fred, compact yourself!" At least this is how I always thought about message sending.