From: Gareth Adams Date: 2007-07-04T23:26:33+09:00 Subject: Re: Choice of the word Wayne E. Seguin gmail.com> writes: > The word Inject essentially means to introduce something into a > system and yet the inject method iterates over a series elements > carrying forward some sort of result at each next step. > > Hence would it not make more sense to name it " accumulate" which > seems to me more explicit and intuitive? The best I could ever come up with is that the function is `injected` between the elements of the object