From: Sammy Larbi Date: 2007-06-21T23:51:59+09:00 Subject: Re: Code Critique: check if int or float ole __ wrote, On 6/20/2007 5:51 PM: > Thanks Tim and Marcel. > > Would you have thought String.i? and String.f? would make more sense > than Integer() and Float(). But yeah they will probably make for a > better implementation then the regexps. > > >> And about camelCase, it's true, almost no one in Ruby uses >> camelCase. I'd recommend just going with the flow and adoption >> lowercase_and_underscored. >> > > I won't be so easily converted. It's more characters, the character is a > stretch on the keyboard and they are harder to read. Underscores seem > backward to me. > > I found that you pick them up quickly and it isn't any harder than reaching for shift after a while - it's just repetition that's needed to memorize it. Besides that, generally I think its good to stick to the conventions of a particular community. So, when I write Java, I use Java conventions, and when I write Ruby, I use Ruby conventions. It was weird at first, but I picked it up in no time.