From: ole __ Date: 2007-06-21T07:51:23+09:00 Subject: Re: Code Critique: check if int or float Thanks Tim and Marcel. Would you have thought String.i? and String.f? would make more sense than Integer() and Float(). But yeah they will probably make for a better implementation then the regexps. > And about camelCase, it's true, almost no one in Ruby uses > camelCase. I'd recommend just going with the flow and adoption > lowercase_and_underscored. I won't be so easily converted. It's more characters, the character is a stretch on the keyboard and they are harder to read. Underscores seem backward to me. -- Posted via http://www.ruby-forum.com/.