From: James Edward Gray II Date: 2007-06-13T21:49:01+09:00 Subject: Re: a matter of style On Jun 13, 2007, at 7:37 AM, Yossef Mendelssohn wrote: > >>> I have yet to see a practical case where the precedence actually >>> came >>> into play -- and I suspect that, when I do finally see such a thing, >>> readability would benefit from a refactor so that it doesn't come >>> into >>> play after all. >> >> assert_not_nil @enum.find do >> # ... a few lines of search code here ... >> end > > I think Chad's point stands. It seems whatever is encapsulated in the > enum's find search code would be better off as a method on that > object. That would make the test cleaner and then there won't be any > worry about block style precedence. As long as your custom method doesn't take a block... James Edward Gray II